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Working with Text Insets

Text insets in FrameMaker offer a way to single source content by 
sharing chunks of text across multiple files and books. Text insets are 
FrameMaker files that you import by reference into another file. The 
terms used to describe the files used are:

■ Container file (destination file)—This is the file into which you 
import one or more text insets. This is also the file you use to build 
the book you are creating.

■ Text inset (source file)—This is the file that you import into the 
container file. It typically contains content that you want to share 
across multiple files or books.

Setting Up Text Inset Files
You can put each chunk of text into a separate file or place chunks into 
separate flows of a single file. You also have options when you import 
the text inset.

General tips Below are tips for setting up text inset files:

■ To ensure that all styles, conditions, and variables have the same 
names, use the same template as you use for container files. 

■ Name files carefully to make the contents of the files easily 
identifiable. For example, you could name your files as follows:

■ Base the name on the heading the text inset goes with and end 
the name with Intro, Overview, or Proc.

■ Use the Intro suffix for introductory text.

■ Use the Overview suffix for conceptual/explanatory 
material.

■ If writing more than one conceptual topic, use the 
Overview suffix numbered sequentially (for example, 
Overview_1, Overview_2, and so on) to indicate the 
correct order of the text insets.
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■ Use the Proc suffix for procedures.

■ If writing more than one procedure for a topic, use the Proc 
suffix numbered sequentially (for example, Proc_1, Proc_2, 
and so on) to indicate the correct order of the text insets.

■ Text insets inherit the conditional text settings of the container file. Use 
conditions as needed in the text inset files. 

■ If you need a whole text inset to be set up with a condition, apply the 
condition in the text inset file to all of the text. If you apply the 
condition to the whole text inset in the container file, you will lose the 
condition setting when you update the text inset.

■ You cannot use conditions on individual rows in table that is in a text 
inset file. You can, however, use conditions on an entire table in a text 
inset.

■ Import variables into the text inset file—importing variables into the 
container file does not change them in the text insets.

■ Make the first paragraph of each text inset file a small anchor tag and put 
a nonbreaking space as the first character in that paragraph.

■ All headings, figure captions, and table titles will be listed in the main 
book’s TOC, LOF, and LOT, whether the heading, figure caption, or table 
title is in a container or text inset file.

■ All auto-numbered items such as figures and tables will be numbered 
correctly, whether the item is in a container file or a text inset file.

■ Place all text inset files into a book. This permits:

■ Spell checking of all text insets. (The Spell Checking function does not 
work for the text insets in the container file.)

■ Searching and replacing in all text insets. (The Search and Replace 
function skips the text insets in the container file.)

■ Any other book-level functions, such as show/hide conditions or 
importing variables.

Tips for using
flows

■ Follow all of the tips above for separate files.

■ Name each flow carefully to make the flow content identifiable.

■ Consider using flows for all insets for a particular chapter, so that each 
chapter has a single text inset file, with a separate flow for each text inset.

To create a text
inset

1. Create a new, empty file based on your chapter template.

Note: Make sure the file has all of the variables and conditions you need to 
use.
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2. Apply your anchor style to the first paragraph and put a nonbreaking space 
as the first character in that paragraph.

3. Start text in a new paragraph below the one you just created.

4. Save the file to the folder where all the text insets for this book will be, 
giving the file a clear name 

5. Add all text, tables, and figures as you normally would.

6. Make sure that your text ends right at the end of flow symbol and that there 
is no extra paragraph below your text as shown below.

Figure 1: Proper and improper end of flow

Note: If you delete the last paragraph marker, you lose part of the condition 
setting. This means that if you applied a condition to the text at the end 
of the flow before deleting the last paragraph as shown above, you must 
reapply the condition.

7. If you need to create cross references to or from the text inset file, see 
“Creating Cross References and Hypertext Markers” on page 6.

8. Add the file to the text inset book that is in the same folder as the text inset.

9. Run spell check on the text inset book, as needed.

Setting Up Container Files and Importing Text Insets
Below are tips for setting up container files:

■ Place all headings (Heading1, Heading2, and so on) in the container file. 
This makes it possible to use normal cross reference procedures to all 
headings, set up index markers, and so on.

■ Import each text inset file into a small anchor paragraph in the container 
file.

Proper text and end of flow.

Improper text and end of flow. You 
must delete the last paragraph 
marker.
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■ Place index markers in the heading paragraphs in the container files.

■ To open a text inset after you insert into the container file, you must 
double-click any text in the text inset. The text inset does not open if you 
double-click a graphic in the text inset. 

Recommended
options when
importing text

insets

Moving or
renaming

container files

If you need to move a container file from one folder to another or rename the 
file, open the container file and use Save As to move it to a new folder or to 
rename it. This method retains the following:

■ Links to text insets.

■ Links to graphics in both the container file and any text insets.

■ Links to cross-referenced files, but these links are to the cross-referenced 
files in their original locations. If you are also moving the cross-referenced 
container files and want the cross references to refer to the files in their 
new locations, these cross references break. 

■ You can use FrameScript to resolve this issue. A custom script can 
look for the referenced files in the same folder as the container file and 
update the path to the cross referenced file.

To create a
container file

1. Create a new, empty file based on your chapter template.

2. Enter all headings needed in this chapter.

3. After each heading, press Enter to create a new, empty paragraph.

4. Apply your anchor style to the paragraph that you just created.

If using flows, select the flow 
you want.

Text uses all formats from the 
container file as long as 
formats in the text inset file 
have the same names.

Text inset updates when you 
open the file or update the 
book.
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5. With the curser in the empty paragraph, select File > Import > File.

The Import dialog box opens.

6. Select the text inset file you want to import.

Leave the Import by Reference option (the default) selected.

7. Click Import.

The Import Text Flow by Reference dialog box opens.

8. Select the options you need.

Leaving the default options selected, as shown in “Recommended options 
when importing text insets” on page 4, works well.

9. Click Import.

10. Save the file.

11. Continue adding headings and text insets, as needed.

12. Add index markers to the heading paragraphs.

13. If you need to create cross references to or from the container file, see 
“Creating Cross References and Hypertext Markers” on page 6.

14. If you make changes to a text inset, you must do one of the following to 
ensure that the container file has the latest version:

■ After closing the text inset, double-click the text inset and click 
Update Now.

■ From the container file, select Edit > Update References, select the 
two text inset options, and click Update.

■ Update the book.

To change the
name of a text

inset file

1. From the text inset file, select File > Save As and rename the file.

2. Delete the old text inset file.

3. From the container file, delete the text inset by selecting the text inset and 
pressing Delete.

4. Import the newly named text inset file.

To use a
container file in

a book

1. Open the book where you want to use the container file.

2. Add the container file, just as you would add any other file to the book.

3. Update the book, making sure that the Update All Text Insets option is 
selected.

■ Before finalizing the book, run a spell check on the text inset book.

■ If a term or phrase requires you to use search and replace, run the 
search and replace on both your book file and the text inset book file.
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Creating Cross References and Hypertext Markers
Cross references and text insets are a complex matter and the subject of many 
e-mail messages on the various FrameMaker lists. The tables below are an 
attempt at bringing together all of the information about this in one place in an 
understandable form.

Table 1: Summary of how cross references work with text insets

Cross ref from Cross ref to Works? Notes

Text inset file Any container file Partly ■ Must use cross-ref marker as Source Type.

■ Cross reference content updates normally.

■ Link not live in PDF.

■ If you place a hypertext marker before the cross 
reference and apply a character tag to the cross 
reference (this defines the hotspot), the link is live in 
the PDF.

Text inset file Text inset file 
(including within the 
same text inset file)

Partly ■ Must use cross-ref marker as Source Type from the 
container file (not the text inset file).

■ Link tries to be live in the PDF, but is looking for the 
PDF of the text inset book, not the production book.

■ If you place a hypertext marker before the cross 
reference and apply a character tag to the cross 
reference (this defines the hotspot), the link is live in 
the PDF.

Container file Any container file 
(including within the 
same container file)

Yes ■ These work normally—no special procedures needed.

Container file Text inset file Yes ■ Must use cross-ref marker as Source Type from the 
container file, not the text inset file.

■ Link is live in the PDF.

Table 2: Summary of how hypertext markers work with text insets 

Hypertext marker from Hypertext marker to Works? Notes

Text inset file Any container file Yes ■ For links to headings in the inset’s own 
container file, no file name is needed in 
the marker.

■ For links to headings in a different 
container file, use the file name of the 
target container file in the marker.

■ You will receive an error message from 
FrameMaker saying that it is not finding 
the named destination. You can ignore 
this message.
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To create a
cross reference
using a Cross-

Ref marker

1. Open the file to which you need to create the cross reference.

This cross-referenced file may be:

■ a container file that you want to cross reference from a text inset

■ a text inset file that you want to cross reference from a container file 

■ a text inset file that you want to cross-reference from another text inset 
or from within the same text inset.

2. Create a new blank paragraph below the item (Heading, Figure, etc.) that 
you want to cross-reference.

3. Insert a cross-reference to the heading, figure caption, or table title in this 
blank paragraph. 

Note: Make sure that the cross-reference is of the correct format. The marker 
retains the format.

4. Delete only the cross-reference text. 

Note: Because you are deleting only the text, the marker that you need to use 
remains in the file.

Text inset file Text inset file (including 
within the same text inset 
file)

Yes ■ For links within a text inset, no file name 
needed in the marker.

■ For links to a different text inset, use the 
file name of the target inset’s container 
file in the marker.

■ You will receive an error message from 
FrameMaker saying that it is not finding 
the named destination. You can ignore 
this message.

■ Hypertext markers within a text inset file 
do not work in FrameMaker after you 
import the text inset into the container 
file; however, they work in the PDF.

Container file Any container file 
(including within a 
container file)

Yes ■ These work normally; no special 
procedures are needed. 

■ Use the target container’s file name in 
the marker when the link is to a different 
container file.

Container file Text inset file Yes ■ For links to content in a text inset in the 
same container file, no file name is 
needed in the marker.

■ For links to content in a text inset in a 
different container file, use the file name 
of the target container file in the marker.

Table 2: Summary of how hypertext markers work with text insets  (continued)

Hypertext marker from Hypertext marker to Works? Notes
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5. Save, but do not close, the cross-referenced file.

Note: If the cross-referenced file is a text inset file, this means to leave both 
the text inset and the text inset’s container file open.

6. Do one of the following:

■ If the cross-referenced file is a text inset, go to Step 7.

■ If the cross-referenced file is a container file, go to Step 8.

7. If the cross-referenced file is a text inset file, update the text inset by doing 
one of the following:

■ Selecting Edit > Update References from the text inset’s container 
file. 

■ Double-clicking the text inset in the container file, then clicking 
Update Now.

8. Open the file where you want to insert the cross-reference.

9. Select Special > Cross Reference.

10. In the Cross-Reference window, select the container file from the drop-
down list.

■ If the cross-referenced file is a container file, select the container file.

■ If the cross-referenced file is a text inset, select the text inset’s 
container file.

11. From the Source Type list, select Cross-Reference Markers.

12. From the Cross-Reference Markers list, select the marker that you created 
in Step 2. 

Note: A figure, table, or any other number in the cross reference will have a 
? in it instead of the number. You must update the container file or book 
when you are done. This updates these cross references to be correct 
based on the numbering in the container book.

13. If the cross reference is from a text inset file to any other type of file, add 
a hypertext marker before the cross reference and apply a character tag to 
the whole cross reference.

For more information, see Table 2 on page 6.

14. Update the container book, making sure that the Update All Text Insets 
option is selected.
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Moving Files to a New Location
You may need to move your files to a new location for any number of reasons. 
Depending on how you move the files and what you move, your cross 
references and links to text insets may continue to link to the files in their old 
locations, not the new location. 

Custom FrameScript scripts can resolve these issues, saving writers a great 
deal of time. Below is an example of one way to use a script when moving files 
to a new location.

Example of
when a script

can help

For example, as the developers make new builds and revisions available, you 
may want to create new folders for each build and revision to ensure that you 
can go back to a specific version of the documentation that matches each build 
and revision.

Your folder structure might look like this:

■ Framework\UserGuideContainers—Contains the container files and 
main book for your User Guide in each Revision folder.

■ Framework\UserGuideInsets—Contains the text inset files and text 
inset book for your User Guide in each Revision folder.

Continuing with the example folder structure above, if you copy the entire 
Framework folder to a new Build 510 folder, as shown below, all text insets 
and cross references will continue to work with no problem.

Copy all to Build 
510 folder
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However, if you create a new Revision 3 folder below each UserGuide folder, 
you must copy the files from the corresponding Revision 2 folders into the 
Revision 3 folders. The text insets in the copied container book will work, but 
they will stay linked to the text inset files from the Revision 2 folder. 

You can use a custom FrameScript script to relink the text insets to the files in 
the new Revision 3 folder. You tell the script the new Revision folder in which 
to look. The script then looks for each referenced text inset, making sure it 
exists in the selected Revision folder, then changes the path of the linked inset 
to the new Revision folder.

Text Insets and Generated Files
The numbering and content in index markers, headings, tables, and figure 
captions you create in text inset files will be picked up by any generated files 
in the container book. This means that your table of contents (TOC), list of 
figures (LOF), list of tables (LOT), and index files include all paragraph tags 
that you expect them to from both the container files and the text inset files 
used in your container book.

Jumping from
the TOC, LOF,

or LOT

If you try to jump to a specific item that is in a text inset file, for example to a 
figure from the LOF in FrameMaker using Ctrl+Alt+click, the container file 
opens and the whole text inset where the figure appears is selected but does not 
open; however, after you create a PDF file and click a paragraph in the LOF, 
you will go directly to the figure.

Jumping from
the Index

If you try to jump from the index file in FrameMaker to an index marker in a 
text inset file using Ctrl+Alt+click, the text inset file opens and the index 
marker is selected. This behavior is completely normal. You can edit the index 
marker, close the text inset file, then update the container book, and your index 
is updated.
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Creating Help with WebWorks Publisher 2003
Once you have your content set up and working in FrameMaker, you can set 
up the help project in WebWorks Publisher (WWP). WWP works very well 
with text insets and conditions, so the hard part (setting all that up in 
FrameMaker) is already done.

Below are some tips for setting up your WWP projects:

■ The WWP project picks up all content in the FrameMaker book’s 
container files and text inset files.

■ WWP converts all hypertext markers and cross references to hot links, 
regardless of where they are (in a container or text inset file).

■ You can use a help-only condition for related topics and other content that 
you want only in the help output. 

■ You can change the conditions in the WWP project on the fly and all 
content from the container and text inset files changes in your help output.

■ You have two choices for setting up projects:

■ Use a single project and change the conditions in WWP, as needed—
This will change all conditions in both the container and text inset 
files.
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■ Use multiple projects, one for each:

■ Condition, which represents a different product or version.

■ Different FrameMaker book, if you use different books

■ Different help file name—For example, for Product A, you need 
to name the help productA.chm and for Product B, the file needs 
to be productB.chm. This type of situation would be easier to 
handle in different WWP projects that reference the same 
FrameMaker book.

Resources
Your presenters ■ Linda Gallagher

■ 303-450-9076

■ lindag@techcomplus.com

■ www.techcomplus.com 

■ Tammy Van Boening

■ Senior Technical Writer

■ Jeppesen Sanderson, Inc.

■ 303-328-4420

■ ltammy.vanboening@jeppesen.com

WebWorks
Publisher

■ WebWorks Publisher Web site: http://www.webworks.com/

■ E-mail list: http://www.yahoogroups.com search for wwp-user list (you 
must join Yahoo Groups before you can join the list)

FrameMaker ■ Adobe Web site: http://www.adobe.com/products/framemaker/main.html

■ Framers e-mail list: http://lists.frameusers.com/mailman/listinfo/framers

FrameScript Finite Matters Web site: http://www.framescript.com/
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